How to fix vulnerable component jquery on BigCommerce

Update jQuery to the latest stable version (3.7+) to eliminate known cross-site scripting (XSS) and prototype-pollution vulnerabilities that attackers actively exploit.

Steps for BigCommerce

  1. In your BigCommerce Control Panel, go to Storefront → Themes → click 'Advanced' → 'Edit Theme Files' on your active theme (Stencil-based).
  2. In the file editor, open 'templates/layout/base.html' (or the equivalent base layout) and search for jQuery script tags.
  3. Update any hard-coded CDN jQuery URL to 'https://code.jquery.com/jquery-3.7.1.min.js'.
  4. If jQuery is referenced in 'assets/js/app.js' or bundled via Webpack, open 'package.json', update the jQuery version to '^3.7.1', and run 'npm install && stencil bundle' locally before re-uploading the theme.
  5. Check all installed apps in Apps → My Apps — app-injected jQuery must be fixed by the app vendor; contact them or remove outdated apps.
  6. Apply the theme changes and use DevTools → Network to confirm no old jQuery version is loaded.
Official BigCommerce documentation ↗

What is vulnerable component jquery?

jQuery is a JavaScript library that most websites load to make interactive features easier to build. Like any software, older versions of jQuery contain security bugs that have been discovered and publicly documented — these are called CVEs (Common Vulnerabilities and Exposures). When your store loads an outdated jQuery version, it is shipping known security holes directly to every visitor's browser. The fix is simply to replace the old file with a current, patched version.

Outdated jQuery versions (especially anything below 3.5.0) contain confirmed XSS vulnerabilities that allow attackers to inject malicious scripts into your pages — stealing customer payment data, session cookies, or redirecting shoppers to phishing sites. This directly endangers customer trust, can result in PCI-DSS compliance failures, and may expose you to legal liability under GDPR or CCPA if customer data is compromised. Google's Safe Browsing also flags sites that serve known malicious scripts, which can trigger browser security warnings that wipe out organic traffic overnight. OWASP lists Vulnerable and Outdated Components as #6 in its Top Ten most critical web application security risks precisely because these attacks are automated, common, and easy for criminals to run at scale.

See the complete Vulnerable component jquery guide for every platform and the full background.

Not sure if your BigCommerce store has this?

Run a free SEOLZ scan — we’ll find vulnerable component jquery and every other issue across your whole site.

Scan my site free

Fix vulnerable component jquery on another platform